Welcome to our status page. If you are looking for help, please check our
documentation guides or
contact us on our community forum.
All products listed below have a target availability of 99.9%.
The issue remains quiet and has not resurfaced. We are implementing our active monitoring and rapid-response guardrails in place while the engineering team continues investigating the root cause.
Posted Jul 01, 2026 - 20:07 UTC
Monitoring
The immediate issue has been mitigated. However, because this specific failure mode develops gradually over time, we have additional monitoring in place and collecting more diagnostic data to prevent a recurrence.
Posted Jul 01, 2026 - 18:46 UTC
Identified
This issue is causing degraded performance impacting maestro instances and team is currently investigating the issue. Impact: Workflows may experience slowness or get stuck.
Posted Jul 01, 2026 - 17:29 UTC
This incident affected: European Union (Agentic Orchestration).