Upstream outage causing issues with multiple UiPath services

Incident Report for UiPath

Postmortem

Incident Summary
On October 29, 2025, between approximately 16:00 UTC and 00:40 UTC on October 30, 2025, UiPath experienced an outage affecting multiple cloud services. The affected services include:

  • Action Center
  • Agents
  • AI Center
  • Automation Ops
  • Apps
  • Document Understanding
  • Insights

Impact
During this period, customers were unable to access these services through the Cloud Portal due to connectivity issues with our cloud service provider.

Response
We detected the outage through automated alerts and coordinated with our cloud service provider to understand the issue and obtain updates on the resolution.

Root Cause and Resolution
The root cause was attributed to an outage of the Content Distribution Network at our cloud service provider. They have since restored their service, and our services have returned to normal operation.

Next Steps

  1. Internal Review: We will conduct an internal review to assess the outage's impact and identify potential improvements.
  2. CDN Infrastructure Revision: We plan to revise our CDN infrastructure to enhance resilience against similar future incidents.
Posted Oct 30, 2025 - 07:24 UTC

Resolved

The issues have been resolved
Posted Oct 29, 2025 - 23:49 UTC

Monitoring

The upstream issues at our Cloud Service Provider have been mitigated, but some users may still experience intermittent failures from requests being routed to previous endpoints.
Posted Oct 29, 2025 - 22:57 UTC

Update

Functionality has been restored for almost all services, users may still experience intermittent failures due to the rolling nature of the fixes being applied
Posted Oct 29, 2025 - 22:46 UTC

Update

UiPath service functionality continues to recover as fixes are rolled out globally.
Posted Oct 29, 2025 - 22:03 UTC

Update

UiPath service functionality continues to recover as fixes are rolled out globally.
Posted Oct 29, 2025 - 21:11 UTC

Update

UiPath service functionality continues to recover as fixes are rolled out globally.
Posted Oct 29, 2025 - 21:03 UTC

Update

UiPath service functionality continues to recover as fixes are rolled out globally by the upstream service provider. We are continuing to investigate other mitigation steps available to us.
Posted Oct 29, 2025 - 20:16 UTC

Update

The service provider estimates all issues will be resolved within 4 hours, and we are seeing some UiPath service functionality recover as the fixes are rolled out globally. We are continuing to investigate other mitigation steps available to us.
Posted Oct 29, 2025 - 19:28 UTC

Identified

The service provider has identified a fix and is currently rolling it out, but the impacted UiPath services have not yet started recovering
Posted Oct 29, 2025 - 18:41 UTC

Update

Our Cloud Service Provider is working to resolve the issue, but does not yet have an ETA for when it will be resolved.
Posted Oct 29, 2025 - 17:51 UTC

Update

Our Cloud Service Provider is working to resolve the issue, we are continuing to assess the scope of the impact to UiPath services.
Posted Oct 29, 2025 - 17:15 UTC

Update

Our Cloud Service Provider is experiencing a major outage, which is affecting the availability of multiple UiPath services. We are investigating to determine the scope of the outage.
Posted Oct 29, 2025 - 17:12 UTC

Update

Our Cloud Service Provider is experiencing a major outage, which is affecting the availability of multiple UiPath services. We are investigating to determine the scope of the outage.
Posted Oct 29, 2025 - 17:06 UTC

Update

Our Cloud Service Provider is experiencing a major outage, which is affecting the availability of multiple UiPath services. We are investigating to determine the scope of the outage.
Posted Oct 29, 2025 - 16:52 UTC

Update

Our Cloud Service Provider is experiencing a major outage, which is affecting the availability of multiple UiPath services. We are investigating to determine the scope of the outage.
Posted Oct 29, 2025 - 16:46 UTC

Update

Our Cloud Service Provider is experiencing a major outage, which is affecting the availability of multiple UiPath services. We are investigating to determine the scope of the outage.
Posted Oct 29, 2025 - 16:32 UTC

Investigating

Our Cloud Service Provider is experiencing a major outage, which is affecting the availability of multiple UiPath services. We are investigating to determine the scope of the outage.
Posted Oct 29, 2025 - 16:22 UTC
This incident affected: Automation Cloud, Orchestrator, Automation Hub, AI Center, Action Center, Apps, Automation Ops, Computer Vision, Cloud Robots - VM, Customer Portal, Data Service, Documentation Portal, Document Understanding, Insights, Integration Service, Marketplace, Process Mining, Task Mining, Test Manager, IXP, Serverless Robots, Studio Web, Solutions Management, Context Grounding, Autopilot for Everyone, Autopilot (Plugins), and Agentic Orchestration.