Welcome to our status page. If you are looking for help, please check our
documentation guides or
contact us on our community forum.
All products listed below have a target availability of 99.9%.
The fix has been deployed and service has been restored
Posted Mar 17, 2026 - 10:50 UTC
Monitoring
A fix has been deployed to address the issue. We are actively monitoring the environment to confirm full service restoration.
Posted Mar 17, 2026 - 10:33 UTC
Update
Our team is making progress in identifying the root cause and is actively working diligently to mitigate the issue. No action is required from customers at this time.
Posted Mar 17, 2026 - 09:47 UTC
Investigating
We are currently investigating degraded performance affecting IXP in the US region.
Affected functionality: - Automations utilizing IXP may experience increased latency - Some requests may return HTTP 503 errors
Next steps: Our team is actively investigating the root cause and working to restore full service. No action is required from customers at this time.