Partial Platform Outage
Incident Report for UiPath
Postmortem

The UiPath Identity service had a partial outage between 06/12/2023 at 23:54 UTC and 06/13/2023 at 01:38 UTC. One production cluster (out of 9 clusters worldwide) was effected. This cluster hosts all Community users some Enterprise users. Identity is a platform service that is used by all of UiPath Automation Cloud, so the impact was seen across many different products.

The outage happened during a database migration. The upgrade caused a performance issue that became so severe that the deployment was aborted mid-way through. Our engineering team detected the issue, scaled up the database, and then manually performed the database upgrade to restore the health of the service.

We realize that this downtime was close to 2 hours, which is unacceptable. We have identified a number of action items to prevent similar issues from happening in the future, as well as improving our processes so that if an issue does happen it can be resolved more quickly.

Posted Jun 15, 2023 - 21:08 UTC

Resolved
Resolved
Posted Jun 13, 2023 - 02:08 UTC
Monitoring
The fix has been successful. We will continue to monitor it to ensure that it does not recur.
Posted Jun 13, 2023 - 01:38 UTC
Identified
We have found the issue and are currently rolling out a fix. We will report back here once the issue is mitigated.
Posted Jun 13, 2023 - 01:31 UTC
Investigating
This is impacting all products for Community users. We are still investigating both the root cause and if there are any other impacted customers.
Posted Jun 13, 2023 - 01:02 UTC
This incident affected: Automation Cloud, Orchestrator, Automation Ops, Cloud Robots - VM, and Document Understanding.