Document Understanding Digitizations failing in Europe region

Incident Report for UiPath

Postmortem

On October 28, 2025, between 15:35-15:10 UTC (17:35-18:10 EET), customers using the Document Understanding OCR service in the West Europe region may have experienced processing delays or failures. The issue was caused by a significant reduction in processing capacity due to infrastructure node failures. The issue was automatically detected and resolved through automated recovery mechanisms. All services returned to normal operation by 18:10 EET. No data was lost during this incident.

To enhance our service's resilience, we're taking proactive steps to reserve additional compute resources. This will help ensure our Document Understanding OCR service remains reliable and performant under varying workloads. We're also collaborating with our service provider to investigate the root cause of the resource shortage and identify further measures to prevent similar incidents in the future.

Posted Oct 31, 2025 - 18:31 UTC

Resolved

The issue is resolved
Posted Oct 28, 2025 - 17:31 UTC

Monitoring

Users of Digitizations in the Europe region may have seen a brief spike in failures, we have scaled up the resources and are seeing errors trend down.
Posted Oct 28, 2025 - 17:05 UTC
This incident affected: Documentation Portal.