About This Site

Welcome to our status page. If you are looking for help, please check our documentation guides or contact us on our community forum. All products listed below have a target availability of 99.9%.

Current UiPath Status

All Systems Operational

Component Status Overview

Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Not available
Loading component status...

Uptime over the past 90 days. View historical uptime.

Elevated error rates with Maestro Instances

Incident Report for UiPath

Postmortem

Customer impact

Between July 2, 2026 at around 20:57 UTC and July 3, 2026 around 01:01 am UTC, some Maestro workflows in Australia and U.S. regions using instance-level operations like Retry, Pause, Resume, Cancel, Migrate, and patch variables were potentially impacted, with workflows appearing to be stuck state.

Root cause

Maestro workflows keep a detailed record of every step they execute, and rely on this record to resume a workflow from where it left off. A recent change introduced inconsistencies into this record for some workflows. As a result, those workflows could not resume and appeared to be stuck.

Detection

The incident was caught on an internal report. While we had alerts in place, the rate of errors was not enough to trigger the alerts.

Response

A cross-team bridge was set up on July 2, 8.57 pm UTC, and engineering started looking into the errors being thrown from workflows from Telemetry. Soon enough, on an analysis of telemetry and commits that were included as a part of the latest release payload, the root cause was identified.

Once that was done, a hotfix was developed and validated to confirm that it addressed the issue. The issue was mitigated once the hotfix was deployed to all affected rings and affected customer workflows were retried to ensure they were running.

Follow-up

We are implementing enhanced monitoring and alerting to detect such issues before they affects customers and implementing guardrails to ensure that these issues do not make it into production code.

Posted Jul 23, 2026 - 13:40 UTC

Resolved

A fix has been deployed to all impacted regions.
Posted Jul 03, 2026 - 01:49 UTC

Update

A fix has been identified and we are working on deploying it. Please note that only instances where instance management operations were performed (Pause, resume, retry, goto, migrate, cancel, patchvariable) were impacted.
Posted Jul 02, 2026 - 23:09 UTC

Identified

We are currently seeing some instance executions become stuck due to elevated error rates following a recent deployment. The root cause has been identified, and our team is actively working to resolve the issue.
Posted Jul 02, 2026 - 21:15 UTC
This incident affected: United States (Agentic Orchestration) and Australia (Agentic Orchestration).