About This Site

Welcome to our status page. If you are looking for help, please check our documentation guides or contact us on our community forum. All products listed below have a target availability of 99.9%.

Current UiPath Status

All Systems Operational

Component Status Overview

Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
— Not available
Loading component status...

Uptime over the past 90 days. View historical uptime.

Multiple Regions - Studio Web - New entities showing up with a delay

Incident Report for UiPath

Postmortem

Customer impact

Between August 18, 2026 at 5:11 am UTC and August 18, 2026 at 11:57 am UTC, newly created entities in a subset of UiPath Cloud tenants could take longer than expected to appear in Studio Web. At the time of initial assessment, newly created entities were appearing with an approximately one-hour delay. Customers in Europe, US, and Japan were affected. Entity creation itself continued successfully, no data was lost, and existing entities were unaffected.

Root cause

The issue was caused by an unusually high volume of asset-creation requests from one tenant. Those requests generated more events than our backend entity-indexing service could process at the same rate, creating a backlog in the event-processing queue. Because Studio Web relies on this service to display newly created entities, new entities appeared only after the backlog was processed.

Detection

The issue was identified by our engineering team by entity processing latency alert, and an incident was declared at 5:11 am UTC on August 18, 2026. By 5:23 am UTC, analysis confirmed the last processed entity was approximately one hour behind.

Response

At 5:32 am UTC, we posted an initial customer update noting delayed visibility for newly created entities in Studio Web. By 6:07 am UTC, investigation identified unusually high asset-creation traffic from one tenant, and at 7:03 am UTC, we adjusted database resources for the affected service to help processing recover.

At 7:59 am UTC, the source of the high request volume had stopped sending requests, and the queue began draining. At 9:59 am UTC, we started a data synchronization process for the affected tenant, and at 10:31 am UTC, we removed the problematic queued events so normal processing could catch up faster. Queue depth decreased from 95,000 items at 8:34 am UTC to 1,000 items at 11:44 am UTC.

The incident was marked mitigated at 11:19 am UTC after processing recovered substantially, and resolved at 11:57 am UTC after processing time returned to normal.

Follow up

Re-trigger data synchronization for the affected tenant and monitor ingestion until the tenant's data is confirmed consistent. Improve entity handling in the indexing backend so the backlog will not pile up at this rate.

Posted Aug 27, 2026 - 03:51 UTC

Resolved

The issue has been resolved, and processing time has returned to normal. Thank you for your patience.
Posted Aug 18, 2026 - 11:57 UTC

Monitoring

The issue has been mitigated, and we expect processing times to return to normal shortly. We are monitoring the recovery closely. Thank you for your patience.
Posted Aug 18, 2026 - 11:19 UTC

Identified

We have identified the cause and are working on a resolution for the issue affecting a subset of tenants in Europe, the United States, and Japan. Thank you for your patience.
Posted Aug 18, 2026 - 09:37 UTC

Update

We continue to investigate the issue affecting a subset of tenants in Europe, the United States, and Japan, where newly created entities may take longer than expected to appear in Studio Web. No data is lost, and existing entities are unaffected.
Posted Aug 18, 2026 - 08:44 UTC

Update

We continue to investigate the issue and are working to identify the root cause and restore normal processing times.
Posted Aug 18, 2026 - 06:48 UTC

Investigating

We are investigating an issue affecting Community accounts where newly created entities may take approximately one hour to appear in Studio Web. No data is lost, and existing entities are unaffected.
Posted Aug 18, 2026 - 05:32 UTC
This incident affected: European Union (Studio Web), United States (Studio Web), and Japan (Studio Web).