Test Manager is facing Degraded Performance in US, Canada, Singapore and UK region

Incident Report for UiPath

Resolved

The issue has been resolved and Test Manager service is healthy again.
Posted Oct 28, 2025 - 13:43 UTC

Update

Deployment of Fix to mitigate is in final stage.
Posted Oct 28, 2025 - 12:52 UTC

Update

Deployment of Fix to mitigate is in progress.
Posted Oct 28, 2025 - 11:55 UTC

Update

Deployment of Fix to mitigate is in progress.
Posted Oct 28, 2025 - 11:00 UTC

Update

Fix to mitigate this issue is being deployed currently
Posted Oct 28, 2025 - 10:08 UTC

Identified

Team has identified the issue and actively working on fix.
Posted Oct 28, 2025 - 09:10 UTC

Investigating

Test Manager is facing Degraded Performance in US, Canada, Singapore and UK region. Team is currently working on mitigation of this issue.
Posted Oct 28, 2025 - 08:17 UTC
This incident affected: Test Manager.