Maestro Page Not Loading for Large Processes

Incident Report for UiPath

Resolved

The fix has been successfully applied, and the Maestro page issue has been resolved. Processes with large numbers of instances now load as expected.
Posted Sep 03, 2025 - 22:04 UTC

Update

We are still in the process of deploying the fix for the Maestro page issue affecting processes with a large number of instances. Our team will share another update once the deployment is complete.
Posted Sep 03, 2025 - 21:18 UTC

Identified

We have found the fix for the issue causing the Maestro page to not load when processes have a large number of instances. Our team is working to implement the solution and will provide an update once it is deployed.
Posted Sep 03, 2025 - 20:20 UTC

Investigating

We are aware of an issue on the Maestro page where processes with large number of instances are unable to load. Our team is investigating and will provide updates as we learn more.
Posted Sep 03, 2025 - 19:50 UTC
This incident affected: Agentic Orchestration.