Data Service Workflows execution and creation affected in Delayed US region

Incident Report for UiPath

Postmortem

Customer impact

Between May 15, 2025, at 14:18 UTC and May 15, 2025, at 15:08 UTC, Data Service in the Delayed Enterprise U.S. region experienced downtime. Most of the Data Service queries failed because the service was not available.

Root cause

A previous deployment introduced a database column exclusively in the Delayed Enterprise U.S. region. Later, we removed this unused column. However, we didn’t know the application code still had references to the column. This caused the incident.

Detection

The problem was detected immediately through our alerting systems. Customers also reported the issue.

Response

The engineering team was promptly engaged. They removed the references to the deleted column. This fixed the Data Service.

Follow-up

To prevent recurrence of this issue:

  • We will add a validation step to our deployments to ensure backward and forward compatibility between the application code and the database schema.
  • We will add automated tests to find schema-related issues before deployment.
  • We will fine-tune our alerting for faster detection of similar problems.
Posted May 16, 2025 - 18:35 UTC

Resolved

The issue has been resolved. Issue started at 2:18PM UTC and was quickly mitigated and resolved. Any workflows triggered between 2:18PM UTC and 3:08PM UTC should be re-triggered. Sorry for the inconvenience.
Posted May 15, 2025 - 15:39 UTC

Investigating

Data Service Workflows execution and creation had an issue for a brief period. This impacted only the Delayed US region. Issue has been resolved. Retriggering the workflows should resolve this issue.
Posted May 15, 2025 - 15:31 UTC
This incident affected: Data Service.