About This Site

Welcome to our status page. If you are looking for help, please check our documentation guides or contact us on our community forum. All products listed below have a target availability of 99.9%.

Current UiPath Status

All Systems Operational

Multiple Regions - Agents - Issue with Conversational agents in Agent Instance Management

Incident Report for UiPath

Postmortem

Customer Impact

Between January 5, 2026, 22:05 UTC and January 14, 2026, 01:30 UTC, some customers experienced an inability to access Conversational Agents through the Agent Instance Management portal across all regions.

When attempting to interact with Conversational Agents, users encountered 404 errors, preventing them from loading or using their agents. Once the issue was resolved, service performance returned to normal levels with no further disruptions observed.

Root Cause

The incident stemmed from a version mismatch between interdependent services. Specifically:

  • The Agent Instance Management service was updated with a new version of the Conversational Agents SDK
  • The corresponding update to the Conversational Agents service was delayed
  • This timing discrepancy resulted in the SDK attempting to access routing endpoints that were not yet available in the deployed version of the Conversational Agents service

The incompatibility between these service versions manifested as 404 errors when customers attempted to access their Conversational Agents.

Detection

The issue was initially identified through routine service verification procedures. Our monitoring systems did not have specific alerts configured to detect 404 errors in this context, representing a gap in our monitoring coverage that will be addressed.

Response

Upon detection, our teams took actions to initiate deployments to synchronize the Conversational Agents service with the updated SDK requirements across all regions.

Service functionality was progressively restored as each region received the updated deployment.

Follow-Up

To prevent similar incidents in the future, we are implementing several improvements:

  • Enhanced change management coordination to ensure synchronized deployments of interdependent services
  • Expanded monitoring capabilities to proactively detect version mismatches between dependent services before they impact customers

These measures will help us maintain service continuity and minimize the potential for similar disruptions in the future.

Posted Jan 16, 2026 - 13:30 UTC

Resolved

The issue has been resolved and all systems are operational. Thank you for your patience.
Posted Jan 14, 2026 - 01:34 UTC

Monitoring

The fix has been successfully deployed to all regions. We are currently monitoring the service to ensure stability and verify that the issue is fully resolved.
Posted Jan 14, 2026 - 01:24 UTC

Update

Remediation is progressing. We have completed the fix rollout for the Canada, India, and UK regions and are monitoring them for stability. Deployment to the remaining regions is currently underway.
Posted Jan 14, 2026 - 00:20 UTC

Update

Remediation is ongoing. We are currently awaiting the completion of the fix rollout. We appreciate your patience as we work to restore service.
Posted Jan 13, 2026 - 23:06 UTC

Identified

We have identified the root cause of the issue and are working on a resolution. We will provide updates as progress is made.
Posted Jan 13, 2026 - 21:55 UTC

Investigating

Our team is investigating issues accessing conversational agents through Agent instance Management.

Affected Regions:
- Europe
- US
- Japan
- Australia
- Canada
- Singapore
- Delayed US
- Delayed EU
- India
- UK
- Switzerland
- UAE
Posted Jan 13, 2026 - 21:05 UTC
This incident affected: European Union (Agents).