ActionCenter - "Wait for Task" activities returning AssignedToUser as null

Incident Report for UiPath

Resolved

A new feature rollout regressed the APIs (GetFormTaskById, GetAppTaskById, and GetTaskDataById) to send back AssignedToUser field as null.
We have rolled back the feature as of now and fixed the data in our backend.
Posted Jun 10, 2025 - 01:24 UTC

Investigating

"Wait for Task" activities are returning the AssignedToUser field as null. The underlying APIs used in the activities were regressed and the field name was changed in the API response
Posted Jun 10, 2025 - 00:10 UTC
This incident affected: Action Center.