Welcome to our status page. If you are looking for help, please check our
documentation guides or
contact us on our community forum.
All products listed below have a target availability of 99.9%.
We observed increased latency affecting Maestro workflow executions in the Europe region between June 12, 2026, 20:00 UTC and June 24, 2026, 15:00 UTC.
Impact: Some Maestro workflows experienced slower-than-normal execution times during this period. No other services were impacted.
The issue was isolated to Maestro workflow execution in the Europe region. Our team has taken corrective actions to restore normal performance and continues to monitor the service to ensure stability.
We apologize for any inconvenience this may have caused.
Posted Jun 25, 2026 - 00:06 UTC
Monitoring
We observed increased latency affecting Maestro workflow executions in the Europe region between June 12, 2026, 20:00 UTC and June 24, 2026, 15:00 UTC.
Impact: Some Maestro workflows experienced slower-than-normal execution times during this period. No other services were impacted.
The issue was isolated to Maestro workflow execution in the Europe region. Our team has taken corrective actions to restore normal performance and continues to monitor the service to ensure stability.
We apologize for any inconvenience this may have caused.
Posted Jun 24, 2026 - 21:43 UTC
This incident affected: European Union (Agentic Orchestration).