Agent & Maestro process instances are currently failing in North Europe region

Incident Report for UiPath

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 22:25 UTC

Monitoring

The issue has been identified and a fix has been implemented. We are monitoring the results.
Posted Jun 16, 2025 - 21:54 UTC

Investigating

We are investigating issues with Maestro and Agents in North Europe region. Agent & Maestro process instances cannot be started and existing processes are not being executed.
Posted Jun 16, 2025 - 21:15 UTC
This incident affected: Agentic Orchestration.