Issues with accessing Orchestrator UI in Automation Cloud across all regions.
Incident Report for UiPath
Resolved
The issue has been resolved. We monitored for a while to ensure there are no issues.
Posted May 25, 2023 - 16:52 UTC
Monitoring
We have identified the issue and applied the mitigation. We are currently monitoring the service.
Posted May 25, 2023 - 16:10 UTC
Update
We are still investigating the issue. We will provide an update as soon as we have new information.
Posted May 25, 2023 - 15:40 UTC
Investigating
Some users have problems accessing Orchestrator UI in Automation Cloud across all regions. Our team is engaged and are actively working to find the cause.
Orchestrator functionality like Jobs and queues is working fine.

As a workaround, clearing the browser cache lets users access Orchestrator UI.
Posted May 25, 2023 - 15:00 UTC
This incident affected: Orchestrator.