About This Site

Welcome to our status page. If you are looking for help, please check our documentation guides or contact us on our community forum. All products listed below have a target availability of 99.9%.

Current UiPath Status

All Systems Operational

Customers will observe latency with the new data in insights in US region

Incident Report for UiPath

Resolved

Issue is resolved now.
Posted Jun 02, 2026 - 18:13 UTC

Update

We have identified the cause of the degraded performance. We are working on the resolution
Posted Jun 02, 2026 - 17:23 UTC

Identified

We have identified the cause of the degraded performance.
Impact: Users may experience latency with the new data from orchestrator in insights in US region
Additional updates will be provided as we move toward resolution.
Posted Jun 02, 2026 - 17:20 UTC
This incident affected: United States (Insights).