Action App Task Creation Failing for Maestro Users in India and UK regions

Incident Report for UiPath

Postmortem

Customer impact

Between Oct 30, 2025 19:08 UTC and Oct 30, 2025 23:06 UTC, customers in India region were unable to create an Action App Task in Maestro process. All other regions were unaffected.

Root cause

During a recent update to application code, a difference in how data was stored between database systems caused Maestro to receive mismatched information from one of its dependent services. This led to errors when creating Action App Tasks in the India region.

Detection

The issue was detected by a customer report.

Response

Once identified, the issue was promptly fixed to ensure consistent behavior across all environments.

Follow-up

To avoid similar issues in the future, we are implementing the following measures:

  • Enhanced API Validation: Introduce automated API tests to identify and flag any data type mismatches or schema inconsistencies early in the deployment process.
  • Database Consistency Fixes: The engineering team has addressed the root cause to ensure consistent data handling across all database environments and the fix is being rolled out globally.
  • Proactive Detection and Alerting: We will enhance our monitoring and alerting mechanisms to proactively detect similar issues before they impact customers.
Posted Nov 07, 2025 - 14:08 UTC

Resolved

The issue has been resolved
Posted Oct 30, 2025 - 23:06 UTC

Update

Some complications were encountered when applying the mitigation, we are working on resolving them to complete mitigation of the issue
Posted Oct 30, 2025 - 22:18 UTC

Update

A mitigation for the issue is being deployed
Posted Oct 30, 2025 - 21:30 UTC

Update

We are still working on a mitigation, which should be available within the next hour
Posted Oct 30, 2025 - 20:44 UTC

Identified

We have identified the issue, and are preparing a fix
Posted Oct 30, 2025 - 19:52 UTC

Investigating

We are aware of the issue and are investigating the cause.
Posted Oct 30, 2025 - 19:15 UTC
This incident affected: Agentic Orchestration.