About This Site

Welcome to our status page. If you are looking for help, please check our documentation guides or contact us on our community forum. All products listed below have a target availability of 99.9%.

Current UiPath Status

All Systems Operational

Delayed US - Autopilot for Everyone - failures accessing Admin UI

Incident Report for UiPath

Postmortem

Customer Impact

From December 8, 2025, 11:47 pm UTC to December 9, 2025, 2:05 am UTC, customers experienced an outage affecting the AI Trust Layer in our Delayed US region.

Multiple UiPath products that depend on this layer — including Autopilot For Everyone, AI Center, and LLMOps — experienced degraded functionality or complete service interruption during this period.

Root Cause

The outage was caused by an incorrect configuration of feature flags controlling the AI Trust Layer, which rendered the service inaccessible.

Detection

Our synthetic monitoring system first identified the issue through automated alerts that detected service failures, triggering our incident response protocol.

Response

Upon alert activation, our team conducted a comprehensive investigation across network and service layers. The investigation identified the root cause as a recently applied feature flag configuration.

Remediation included:

  1. Deploying the correct feature flag configuration across the affected region
  2. Verifying AI Trust Layer accessibility was restored
  3. Confirming all dependent UiPath products automatically resumed normal operation

Full service restoration was achieved immediately following the configuration deployment.

Follow-Up

To prevent similar incidents in the future, we will:

  • Conduct a comprehensive review of our feature flag configuration management strategy and processes
  • Implement enhanced safeguards for configuration rollouts, including pre-deployment validation
  • Strengthen our testing procedures for critical service dependencies
Posted Dec 11, 2025 - 18:00 UTC

Resolved

The incident has been resolved.
Posted Dec 09, 2025 - 02:49 UTC

Monitoring

The fix has been deployed. We are observing the service closely to ensure the issue does not recur.
Posted Dec 09, 2025 - 02:18 UTC

Identified

We have identified the root cause of the issue and are currently implementing a solution.
Posted Dec 09, 2025 - 01:48 UTC

Investigating

Our team is investigating access failures affecting the Admin UI for the Autopilot for Everyone service in the Delayed US region.
Posted Dec 09, 2025 - 01:24 UTC
This incident affected: European Union (Autopilot for Everyone).