About This Site

Welcome to our status page. If you are looking for help, please check our documentation guides or contact us on our community forum. All products listed below have a target availability of 99.9%.

Current UiPath Status

All Systems Operational

DataFabric Service Degraded in EU Region

Incident Report for UiPath

Postmortem

Customer Impact

Between March 10, 2026, 10:15 UTC - 13:36 UTC, Data Fabric customers in Europe experienced increased latency and intermittent failures on DataFabric requests across consumption surfaces (Automation Cloud UI and Workflow Activities). During this period, some customers were unable to load Data Fabric UI pages or successfully run workflow activities— affected requests frequently timed out or were canceled by the client (observed as HttpClient timeouts / TaskCanceledException). No durable impact was introduced.

Root Cause

  • A large-scale background maintenance job in the Europe ring temporarily increased demand on the database, slowing responses.
  • At the same time, a deployment and the resulting transient increase in user requests exposed that a subset of service instances did not have enough capacity to absorb the increased, sustained load.
  • The combination of slower database responses and insufficient transient capacity increased the time requests remained open and caused more work to accumulate on active service instances, which further degraded performance. This resulted in worsening performance and intermittent failures for some customers.

Detection

The issue was first detected by a customer report— and automated alerts were subsequently triggered.

Response

Upon receiving the report, the team immediately triaged the issue and identified elevated dependency latency and unhealthy runtime instances.

Around 10:52 UTC, we received the customer report, engaged, and started investigating the issue. We initiated a rollback of the recent deployment at around 12:29 UTC and increased runtime capacity as an stabilizing measure to curb customer impact. These steps together returned the service to a healthy state by 13:36 UTC.

Follow-Up

  • Review and align service instance resource allocations across regions so instances have sufficient headroom for transient load.
  • Improve operational observability to capture runtime diagnostics and memory/health signals earlier.
  • Add proactive alerts for sustained high resource usage and service restarts.
  • Implement operational guardrails for background jobs to prevent database overload/pressure.
Posted Mar 16, 2026 - 08:28 UTC

Resolved

The issue has been resolved. The system has remained stable during the monitoring period.
Posted Mar 10, 2026 - 14:39 UTC

Monitoring

A fix has been deployed and the service is recovering.
Current status: We are monitoring the system to ensure stability and full recovery. Further updates will be shared soon
Posted Mar 10, 2026 - 13:43 UTC

Investigating

We are currently investigating reports of an issue in DataFabric in the Europe region.

Impact: Customers using Data Fabric in the EU Production Automation Cloud may experience intermittent degraded performance and failed requests

Our teams are actively working to identify the cause and assess the scope of the issue. Further updates will be shared as soon as more information becomes available.
Posted Mar 10, 2026 - 12:39 UTC
This incident affected: European Union (Data Service).