Degraded performance for Cloud Apps

Incident Report for UiPath

Resolved

This incident has been resolved.
Posted May 01, 2025 - 17:46 UTC

Investigating

We are currently investigating this issue.
Posted May 01, 2025 - 17:33 UTC
This incident affected: Apps.