About This Site

Welcome to our status page. If you are looking for help, please check our documentation guides or contact us on our community forum. All products listed below have a target availability of 99.9%.

Current UiPath Status

All Systems Operational

Component Status Overview

Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Not available
Loading component status...

Uptime over the past 90 days. View historical uptime.

Resolved - Partial Outage in US region - Document Understanding

Incident Report for UiPath

Postmortem

Customer impact

Between June 17, 2026 at 23:11 UTC and June 18, 2026 at 1:19 UTC (about 2 hours and 8 minutes), customers using Document Understanding in the US region experienced failures on write operations and related actions. Because much of Document Understanding's runtime functionality depends on the ability to write data, affected users also experienced broader runtime degradation during this window.

The impact was limited to the US region. No data was lost, and the service was fully restored at 1:19 UTC on June 18, 2026.

Root cause

The incident was caused by the Document Understanding production database in the US region reaching its maximum configured storage limit. Once the database reached that limit, operations that needed to write new data failed, which caused disruptions for Document Understanding users.

Detection

The issue was detected by automated application monitoring, which alerted the team within approximately 10 minutes of the onset of impact. Our incident response process was initiated immediately, and responders engaged to investigate.

Response

Responders investigated database storage usage and identified that the database had reached its storage capacity limit. To restore write capability, the team increased the database's capacity. A status page update was published at 23:39 UTC identifying the impact to Document Understanding write operations in the US region, with further updates as the scale-up progressed. Successful operations began recovering at 01:18 UTC, and the incident was resolved at 01:19 UTC on June 18, 2026.

Follow up

  We are taking the following actions to prevent recurrence and reduce the impact of similar events:

  • Automated storage-capacity alerts for the Document Understanding databases so the team is warned well before a database approaches its limit.

  • Investigating the database's storage growth to right-size capacity and manage data retention.

  • Migrating the database to a higher-capacity tier so it is no longer constrained by the previous storage ceiling and can scale more quickly.

Posted Jul 30, 2026 - 10:44 UTC

Resolved

The outage has been resolved and Document Understanding in US region is fully operational.
Posted Jun 18, 2026 - 01:19 UTC

Update

Fix is underway and additional updates will be provided as we move toward resolution.

Impact: Users may be unable to write and perform certain operations in US region on Document Understanding.
Posted Jun 18, 2026 - 01:11 UTC

Update

Impact: Users may be unable to write and perform certain operations in US region on Document Understanding.

Next update: Our teams are working to understand the cause and scope and will share updates as available.
Posted Jun 18, 2026 - 00:09 UTC

Identified

We have identified the cause of the degraded performance impacting write operations for Document Understanding in US region and are working on mitigation.

Impact: Users may experience failures on some of the write operations.
Additional updates will be provided as we move toward resolution.
Posted Jun 17, 2026 - 23:39 UTC
This incident affected: United States (Document Understanding).