Agentic Orchestration / Maestro Processes Stalling for Customers in India and UK Regions

Incident Report for UiPath

Resolved

Incident has been marked as resolved.
Posted Sep 02, 2025 - 10:22 UTC

Monitoring

Fix has been implemented and we continue to monitoring
Posted Sep 02, 2025 - 09:41 UTC

Investigating

Few customers in CEI and UKS regions would see their maestro processes unable to progress. We are working on identifying the root cause
Posted Sep 02, 2025 - 09:21 UTC
This incident affected: Agentic Orchestration.