About This Site

Welcome to our status page. If you are looking for help, please check our documentation guides or contact us on our community forum. All products listed below have a target availability of 99.9%.

Current UiPath Status

All Systems Operational

US - IXP - Performance Degradation

Incident Report for UiPath

Postmortem

Customer Impact

Between 09:41 UTC and 13:24 UTC, customers using IXP in the U.S. experienced generally poor performance in the form of slow API requests.

In addition, these specific actions had increased error rates:

  • Consuming stream
  • Uploading documents

For a small number of specific clients, streams were unable to be consumed entirely during this time.

Root Cause

An IXP database migration took place in the U.S. region at 09:41 UTC on February 3, 2026.

This migration changed the underlying database queries used by several of our API routes. One of these database queries was poorly optimized, leading to bad performance when executed against the high volume of data present in the U.S. region. This database query was used by the streams and document upload routes.

Detection

Our engineering team was closely monitoring the migration, and observed an increase in stream response times. In addition, automated alerts picked up on the increased error rates and automatically alerted us while an investigation was underway.

Response

The team worked to find and fix the problem with the database query. At 13:04 UTC, a hotfix was deployed. By 13:24 UTC, API response times and IXP performance had returned to normal.

Follow-Up

We recognize how disruptive this incident was for our customers, especially those relying on timely document processing and stream analytics. The IXP team will ensure that in future, similar migrations:

  • Have better performance testing
  • Have faster rollback capabilities
Posted Feb 05, 2026 - 15:05 UTC

Resolved

The incident has been resolved and system performance has returned to normal. A postmortem will be shared soon with additional details.
Posted Feb 03, 2026 - 13:39 UTC

Monitoring

The fix has been applied and we are seeing improvements in system performance through our monitoring systems. We will continue to closely monitor performance for some time before marking the incident as resolved.
Posted Feb 03, 2026 - 13:24 UTC

Update

Our hotfix deployment is currently in progress. We will provide an update once the deployment is complete and we begin monitoring system behavior to ensure performance is fully restored
Posted Feb 03, 2026 - 12:54 UTC

Identified

Our engineering team has identified a fix and is actively working on rolling it out to restore normal performance.
Posted Feb 03, 2026 - 12:05 UTC

Update

We have identified the issue our engineering team is actively working on a fix to restore normal performance. Our investigation also indicates that the issue is affecting overall IXP performance in the US region, and is not limited to Streams
Posted Feb 03, 2026 - 11:16 UTC

Investigating

We are currently investigating an issue causing performance degradation and increased latency for Streams in the US region. Some customers may experience slow response times (exceeding 5 minutes) and request timeouts when calling Streams
Posted Feb 03, 2026 - 10:08 UTC
This incident affected: European Union (IXP).