Increased Request Latency for Orchestrator Service for some customers in US Region

Incident Report for UiPath

Postmortem

Customer impact

On February 19, from 12:20 pm UTC to 2:20 pm UTC, some customers in the U.S. region experienced delays in real-time data updates on Orchestrator pages, like Jobs and Queues.

Root cause

Our investigation identified a significant lag in data synchronization between primary and read-only replica databases in the U.S. region. This problem has affected some of our clients. It happened when a database maintenance runbook was being run. These runbooks are scheduled daily at the lowest regional traffic time . But a bug had previously prevented their execution, resulting in a backlog of data awaiting cleanup.

Detection

The synchronization delays were not initially detected by our alert system and were brought to our attention by customer reports

Response

We fixed the problem by stopping the database maintenance runbook. This fixed the synchronization delay right away.

Follow-up

To prevent future occurrences, we have implemented measures to monitor and detect data synchronization issues proactively. Additionally, we are developing improvements to minimize the performance impact of these maintenance runbooks.

Posted Feb 21, 2025 - 07:37 UTC

Resolved

The Issue has been resolved after the fix has been implemented, We will keep monitoring this further.
Posted Feb 19, 2025 - 16:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2025 - 14:41 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 19, 2025 - 14:40 UTC

Investigating

Starting Feb 19, 12:10 PM UTC, some customers in the US region have been experiencing increased request latency for the Orchestrator service. Our team is investigating the issue and will provide updates as we learn more.
Posted Feb 19, 2025 - 14:28 UTC
This incident affected: Orchestrator.