Welcome to our status page. If you are looking for help, please check our
documentation guides or
contact us on our community forum.
All products listed below have a target availability of 99.9%.
This incident has been resolved. All missing Maestro execution trails in the UK region have been restored, and new execution trails are being recorded normally. Instance executions were not impacted at any point. We apologize for the inconvenience this may have caused.
Posted Sep 27, 2026 - 00:36 UTC
Update
We are in the final stage of restoring the missing Maestro execution trails in the UK region, with only a small number of trails remaining. We expect restoration to be complete soon and will post a final update once this incident is resolved.
Posted Sep 27, 2026 - 00:07 UTC
Update
Restoration of the missing Maestro execution trails in the UK region is nearly complete. We are finishing the remaining work and expect to resolve this incident shortly.
Posted Sep 26, 2026 - 22:55 UTC
Update
Restoration of the missing Maestro execution trails in the UK region is progressing, and a portion of the affected trails have been recovered. Work is ongoing to restore the remainder.
Posted Sep 26, 2026 - 21:39 UTC
Update
We are continuing to restore the missing Maestro execution trails in the UK region. New execution trails are unaffected and continue to be recorded normally. We will share another update as progress is made.
Posted Sep 26, 2026 - 20:22 UTC
Update
The fix for Maestro execution trails in the UK region is holding, and new trails continue to be recorded normally. We are still working on restoring the missing trails for affected executions and will provide another update when that's complete.
Posted Sep 26, 2026 - 18:58 UTC
Monitoring
A fix has been applied for the issue affecting Maestro execution trails in the UK region, and new execution trails are being recorded normally. We are restoring the missing execution trails for affected executions and are monitoring the results. Instance executions were not impacted.
Posted Sep 26, 2026 - 17:46 UTC
Identified
We have identified the cause of the issue affecting Maestro execution trails in the UK region and are working on a fix.
Posted Sep 26, 2026 - 17:15 UTC
Investigating
We are investigating issues with Maestro execution trails in the UK region. Some customers may observe the execution trail missed. No impact to instance's executions.
Posted Sep 26, 2026 - 16:46 UTC
This incident affected: UK (Agentic Orchestration).