Orchestrator - some of the customers in US might experience high latency

Incident Report for UiPath

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 07:29 UTC

Monitoring

We recently experienced high latency in our application caused by elevated CPU usage at the database level. To address this, we performed a database scale-up to improve performance and stabilize the system. The issue has been mitigated, and we are closely monitoring the environment to ensure continued stability.

We are further investigating the root cause of this spike in usage and will take preventive actions accordingly.

Thank you for your patience as we work to maintain optimal system performance.
Posted Mar 20, 2025 - 06:28 UTC

Investigating

we are currently investigating the issue
Posted Mar 20, 2025 - 05:24 UTC
This incident affected: Orchestrator.