About This Site

Welcome to our status page. If you are looking for help, please check our documentation guides or contact us on our community forum. All products listed below have a target availability of 99.9%.

Current UiPath Status

All Systems Operational

IXP indexing is degraded in Europe and US region

Incident Report for UiPath

Postmortem

Customer Impact

Between 2026-01-21 18:00 UTC and 2026-01-23 15:43 UTC, background re-inference of IXP Unstructured and Complex Documents (IXP-UCD) design-time predictions was unavailable in EU and US regions. During this period, customers viewing IXP-UCD documents did not see pre-computed predictions, and background prediction error rates appeared as 100%.

Root Cause

The incident was caused by a significant increase in IXP-UCD design-time load in the EU and US regions. This increased load led to a growing backlog of background inference jobs, which in turn caused newly uploaded documents to take over an hour to appear in the IXP-UCD documents table.

The root issue was that document uploads and background re-inference processing were coupled together, meaning that when background jobs became backlogged, they blocked new documents from appearing promptly for users.

Detection

Slow document uploads were spotted by the engineering team through internal use of the platform.

Response

Upon detection:

  • The engineering team identified that background re-inference was causing significant delays in document availability.
  • To prioritize core functionality, background re-inference of design-time predictions was temporarily disabled. This restored timely document uploads but eliminated pre-computed predictions during the affected period.
  • The team then worked to re-enable automatic updating of design-time IXP-UCD predictions so users could see pre-computed predictions and meaningful error rates.
  • A fix was deployed to ensure that newly uploaded documents appear immediately in the documents table without being affected by background processing.

Services were fully restored by 2026-01-23 15:43 UTC, with both document uploads and background predictions functioning normally.

Follow-Up

To prevent similar incidents in the future, we are taking the following steps.

Short term:

  • Decouple document uploads from background re-inference to ensure core workflows are not impacted by background processing.

Long term:

  • Improve load management and capacity handling for IXP-UCD design-time workflows to ensure consistent performance during traffic spikes.
  • Introduce additional safeguards and circuit breakers to prevent background processing from impacting core user workflows.
Posted Jan 30, 2026 - 16:27 UTC

Resolved

We are continuing to monitor for any further issues. Thank you for yourpatience.
Posted Jan 23, 2026 - 17:45 UTC

Update

We are continuing to monitor for any further issues. Thank you for yourpatience.
Posted Jan 23, 2026 - 16:20 UTC

Update

We are continuing to monitor for any further issues. Thank you for your continued patience.
Posted Jan 23, 2026 - 15:26 UTC

Update

We are continuing to monitor for any further issues. Thank you for your patience.
Posted Jan 23, 2026 - 14:38 UTC

Update

We are continuing to monitor for any further issues.
Posted Jan 23, 2026 - 13:37 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2026 - 12:28 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 23, 2026 - 12:18 UTC

Identified

Automated background prediction services impacted in design time in US and Europe for IXP Unstructured & Complex Documents. Users can still upload documents and manually request predictions. Thank you for your patience.
Posted Jan 23, 2026 - 11:18 UTC

Investigating

We are currently investigating this issue.
Posted Jan 23, 2026 - 11:07 UTC
This incident affected: European Union (IXP).